Homework

  1. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    .............................................................................................................
    CCNA 2
    CISCO DISCOVERY PROTOCOL (CDP)
    ............................................................................................................

    Cisco Discovery Protocol (CDP) is a OSI Layer 2 protocol. Ooperates between Cisco devices (Rs, SWs).

    CDP messages contain information about the device such as device ID, platform, connected interface, IOS version, and Layer 3 address.

    Because CDP operates at Layer 2, only directly connected devices exchange information. 
    ...........................................................................................................

    Examine CDP show commands

    (1) View CDP configuration settings
    - from R1, show cdp
    - from R1, show cdp ?
    - from R1, show cdp interface
    - from R1 interface, show cdp interface fa0/0
    - from R1 interface, interface s0/0/0show cdp

    (2) View CDP neighbor information
    - from R1, show cdp neighbors
    (info about SW1 and R2, but not R3 ... R3 not directly connected)

    - from R1, show cdp entry R2
    (more detailed information about R2)

    - from R1,
    show cdp entry
    (detailed information about all directlyconnected devices

    - from R1, show cdp neigbors detail
    (same information as show cdp entry)
    ...........................................................................................................

    Examine CDP configuration commands

    (1) Disable and enable CDP globally on a R
    - from R2, show CDP neighbors
    (output from 3 directly connected devices shows up)

    - from R2 global config, no cdp run
    (disable CDP on R)

    - from R2, show cdp neighbors
    (CDP not enabled)

    - from R1, show cdp neighbors
    (entry for R2 not shown (wait a while))

    - from R2 global, cdp run
    (to enable CDP on the R)


    (2) Disable and enable CDP on interface
     
  2. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ....................................................................................................
    CCNA 2, Mapping a Network with CDP and Telnet
    ...........................................................................................................

    CDP show commands can be used to discover information about unknown devices in a network ... information about directly connected Cisco devices IP address can be used to reach the device.

    We then can Telnet to the device and repeat the process until the entire network is mapped.

    ............................................................................................................

     
  3. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ...........................................................................................................
    CCNA 2, BASIC STATIC ROUTE CONFIGURATION
    ..........................................................................................................

    (1) Erase and Reload the Routers

    - erase startup-config
    - reload
    ..........................................................................................................

    (2) Basic Router Configuration (all Rs)

    Global config commands
    - hostname
    - no ip domain-lookup
    - enable secret



    Config console & virtual terminal line passwords


    Add logging synchronous command to console, virtual terminal lines

    R1(config)# line console 0
    R1(config-line)# logging synchronous
    R1(config-line)# line vty 0 4
    R1(config-line)# logging synchronous


    Add exec-timeout 0  0 to console, virtual terminal lines

    R1(config)# line console 0
    R1(config-line)# exec-timeout 0 0
    R1(config-line)# line vty 0 4
    R1(config-line)# exec-timeout 0 0

    .........................................................................................................

    (3) Interpreting Debug Output

    R1# debug ip routing
     
    - do before configuring IP Addressing etc

    Configure R1's LAN interface
    R1# config terminal
    R1(config)# interface fa0/0
     .
     .
    control z
    ...........................................................................................................

    (4) Look at Routing Table

    R1#
    show ip route#
    Gateway of last resort is not set
    (172.16.0.0/24 is subnetted, 1 subnets)
    (C 172.16.3.0 is directly connected, fa0/0)

    ...........................................................................................................

    (5) Configure R1's WAN interface connected to R2

    R1# config terminal
    R1(config)# interface s/0/0/0
     .
     .
    ............................................................................................................

    (6) Configure R2s WAN interface connected to R1

    R2# debug ip routing
    R2# config terminal
    R2(config)# interface s0/0/0

    ............................................................................................................

    (7) Confirm the new route in Routing Table for R1 and R2

    R1# show ip route
    Gateway of last resort is not set
    (172.16.0.0/24 is subnetted, 2 subnets)
    (C 172.16.2.0 is directly connected, s0/0/0)
    (C 172.16.3.0 is directly connected, fa0/0)


    R2# show ip route
    Gateway of last resort is not set
    (172.16.0.0/24 is subnetted, 1 subnets)
    (C 172.16.2.0 is directly connected, s0/0/0
    ............................................................................................................

    (8) Turn off debugging

    R1# no debug ip routing
    R2# no debug ip routing
    ............................................................................................

    (9) Finish Configuring Router Interfaces

    - Configure remaining R2 interfaces (see Topology, Address Table
    - Configure R3 necessary interfaces
    ..............................................................................................

    (10) Configure IP Addressing on PCs

    ................................................................................................

    (11) Test and Verify Configurations

    Test connectivity
    - from PC1 ping default gateway   (c'est bon!)
    - from PC2 ping default gateway   (c'est bon!)
    - from PC3 ping default gateway   (c'est bon!)

    Ping to test connectivity between directly connected Routers
    - from R2, ping R1 s0/0/0   (c'est bon!)
    - from R2, ping R3 s0/0/1   (c'est bon!)

    Ping to check connectivity between PCs not directly connected
    - ping from PC3 to PC1   (ping fail!)
    - ping from PC3 to PC2   (ping fail!)
    - ping from PC2 to PC1   (ping fail!)
    - ping from PC1 to PC3   (ping fail!)

    At this point Rs only know about directly connected networks
    ......................................................................................................
    (7) Gather Information

    Check status of interfaces
    - R1# show ip interface brief
    - R2# show ip interface brief
    - R3# show ip interface brief
    (everything up and up)

    View Routing Table information for all 3 Routers

    - R1# show ip route
    Gateway of last resort is not set
    172.16.0.0/24 is subnetted, 2 subnets
    (C  172.16.2.0 directly connected , s0/0/0)
    (C  172.16.3.0 directly connected , fa0/0)

    - R2# show ip route
    Gateway of last resort is not set
    172.16.0.0/24 is subnetted, 2 subnets
    (C  172.16.1.0 directly connected , fa0/0)
    (C  172.16.2.0 directly connected , s0/0/0)
    (C  192.168.1.0/24 directly connected , s0/0/1)

    - R3# show ip route
    Gateway of last resort is not set
    (C  192.168.1.0/24 directly connected , s0/0/1)
    (C  192.168.2.0/24 directly connected , fa0/0)

    At this point, routers not configured with static or dynamic routing. Therefore routers only know about directly connected networks.

    .................................................................................................................
     
  4. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ..............................................................................................................
    CCNA 2, BASIC STATIC ROUTE CONFIGURATION (continued)
    .............................................................................................................

    STATIC ROUTE configuration using a NEXT HOP ADDRESS

    R(config)# ip route network-address subnet-mask ip-address
    - network-address (destination network address)
    - subnet-mask (destination subnet mask, but can be group summarized)
    - ip-address (next hop Router IP address)
    ............................................................................................................

    (1) On R3, config static route to reach 172.16.1.0 network

    R3(config)# ip route 172.16.1.0 255.255.255.0 192.168.1.2
    172.16.1.0 (destination network address ... R2 LAN)
    255.255.255.0 (destination subnet mask)
    192.168.1.2 (R2 s0/0/1 as next hop address)

    R3 uses s0/0/1 as interface to forward packets to 172.16.1.0/24 network


    View Routing Table to verify new static route entry

    R3# show ip route
    Gateway of last resort is not set
    172.16.0.0/24 is subnetted, 1 subnets
    (S  172.16.1.0  [1/0] via 192.168.1.2)
    (C  192.168.1.0/24 directly connected , s0/0/1)
    (C  192.168.2.0/24 directly connected , fa0/0)

    note at this point PC2 can ping PC3, but PC3 cannot ping PC2
    ..........................................................................................................

    (2) On R2, config static route to reach 192.168.2.0 network

    R2(config)# ip route 192.168.2.0 255.255.255.0 192.168.1.1
    192.168.2.0 (destination network address ... R3 LAN)
    255.255.255.0 (destination subnet mask, but can be summarized)
    192.168.1.1 (R3 s0/0/1 as next hop address)


    View Routing Table to verify new static route entry

    R2# show ip route
    Gateway of last resort is not set
    172.16.0.0/24 is subnetted, 2 subnets
    (C  172.16.1.0 directly connected , fa0/0)
    (C  172.16.2.0 directly connected , s0/0/0)
    (C  192.168.1.0/24 directly connected , s0/0/1)
    (S 192.168.2.0/24 [1/0] via 192.168.1.1)

    note at this point PC2 can ping PC3, and PC3 can ping PC2
    ............................................................................................................

    STATIC ROUTE configuration using an EXIT INTERFACE


    R(config)# ip route network-address subnet-mask exit-interface
    network-address (destination network address)
    subnet-mask (destination subnet mask, can be group summarized)
    exit-interface (outgoing interface used to forward to destination network)

    (1) On R3, config static route to the 172.16.2.0 network

    R3(config)# ip route 172.16.2.0 255.255.255.0 s0/0/1
    172.16.2.0 (destination network address ... R1/R2 WAN)
    255.255.255.0 (destination subnet mask, can be group summarized)
    so/0/1 (s0/0/1 interface of R3 ... exit interface)

    R3# show ip route
    Gateway of last resort is not set
    172.16.0.0/24 is subnetted, 2 subnets

    (S  172.16.1.0  [1/0] via 192.168.1.2)
    (S  172.16.2.0 is directly connected, s0/0/1)
    (C  192.168.1.0/24 directly connected , s0/0/1)
    (C  192.168.2.0/24 directly connected , fa0/0)

    R3# show running-config
     .
     .
    ip route 172.16.1.0 255.255.255.0 192.168.1.2
    ip route 172.16.2.0 255.255.255.0 Serial0/0/1

     .
     .
    ...........................................................................................................

    (2) On R2, config static route to the 172.16.3.0 network


    R2(config)# ip route 172.16.3.0 255.255.255.0 s0/0/0
    172.16.3.0 (destination network address ... R1 LAN)
    255.255.255.0 (destination subnet mask, can be group summarized)
    s0/0/0 (s0/0/0 interface of R2 ... exit interface)

    R2# show ip route  
    Gateway of last resort is not set
    172.16.0.0/24 is subnetted, 3 subnets

    (C  172.16.1.0 directly connected , fa0/0)
    (C  172.16.2.0 directly connected , s0/0/0)
    (S  172.16.3.0 directly connected, s0/0/0)
    (C  192.168.1.0/24 directly connected , s0/0/1)
    (S 192.168.2.0/24 [1/0] via 192.168.1.1) 

    - ping connectivity between PC2 and PC1 fail
    - R1 does not have a return route to the 172.16.1.0 network

    ...........................................................................................................

    DEFAULT STATIC ROUTE configuration

    R(config)# ip route 0.0.0.0 0.0.0.0 { ip-address | interface }

    Configure R1 with a default route using the interface option on s0/0/0 of R1 as the next hop interface.

    R1(config)# ip route 0.0.0.0 0.0.0.0 172.16.2.2

    R1# show ip route
    Gateway of last resort is 172.16.2.2 to network 0.0.0.0
    172.16.0.0/24 is subnetted, 2 subnets

    (C  172.16.2.0 directly connected , s0/0/0)
    (C  172.16.3.0 directly connected , fa0/0)
    (S* 0.0.0.0/0 [1/0] via 172.16.2.2)

    Note that the R1 router now has a default route (gateway of last resort), and will send all unknown traffic out s0/0/0, which is connected to R2.

    PC2 can ping PC1
    PC3 cannot ping PC1 (172.16.3.0 network not in R3 Routing Table)
    ...........................................................................................................

    SUMMARY STATIC ROUTE configuration

    PC3 cannot ping PC1 (172.16.3.0 network not in R3 Routing Table)
    R3 already has two static routes
    - S*  172.16.2.0/24
    - S*  172.16.1.0/24

    We could configure another static route on R3 for the 172.16.3.0 network ... we already have two static routes to 172.16.2.0/24 and 172.16.1.0/24 ... Because 172.16.3.0 network is close to 172.16.2.0/24 and 172.16.1.0/24 we can summarize these into 1 route, therefore reduce size of routing tables, therefore route lookup process more efficient.

    Looking at the three networks at the binary level, we can a common boundary at the 22nd bit from the left.

    172.16.1.0 10101100.00010000.00000001.00000000
    172.16.2.0 10101100.00010000.00000010.00000000
    172.16.3.0 10101100.00010000.00000011.00000000

    The prefix portion will include 172.16.0.0, because this would be the prefix if we turned off all the bits to
    the right of the 22nd bit.

    Prefix 172.16.0.0

    To mask the first 22 left-most bits, we use a mask with 22 bits turned on from left to right:

    Bit Mask 11111111.11111111.11111100.00000000

    This mask, in dotted-decimal format, is ...
    Mask 255.255.252.0



    Configure the Summary Static Route R3

    R3(config)# ip route 172.16.0.0 255.255.252.0 192.168.1.2
    172.16.0.0 (prefix portion summary static route)
    255.255.252.0 (subnet mask portion of summary static route)
    192.168.1.2 (R2 s0/0/1)


    R3# show ip route
    Gateway of last resort is not set
    172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks

    (S 172.16.0.0/22 [1/0] via 192.168.1.2)
    (S  172.16.1.0/24  [1/0] via 192.168.1.2)
    (S  172.16.2.0/24 is directly connected, s0/0/1)
    (C  192.168.1.0/24 directly connected , s0/0/1)
    (C  192.168.2.0/24 directly connected , fa0/0)

    Configuring a summary route on R3 did not remove the static routes configured earlier (they are more specific routes). They both use /24 mask ... the new summary will be using a /22 mask. To reduce the size of the routing table, we can now remove the more specific /24 routes.
    ............................................................................................................

    Remove Static Routes on R3

    R3(config)# no ip route 172.16.1.0 255.255.255.0 192.168.1.2
    R3(config)# no ip route 172.16.2.0 255.255.255.0 s0/0/1

    R3# show ip route

    Gateway of last resort is not set
    172.16.0.0/22 is subnetted, 1 subnets
    (S 172.16.0.0 [1/0] via 192.168.1.2)
    (C 192.168.1.0/24 is directly connected, s0/0/1)
    (C 192.168.2.0/24 is directly connected, fa0/0)


    R3 now only has 1 route to any host belonging to 172.16.0.0/24, 172.16.1.0/24, 172.16.2.0/24, and 172.16.3.0/24. Traffic destined for these networks will be sent to R2 at 192.168.1.2.

    Ping PC3 to PC1 good now.

    .............................................................................................................
     
  5. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    .........................................................................................................

    CCNA 2, Static Routes
    .........................................................................................................

    (1) Using Next-Hop Address Static Route

    R3(config)# ip route 172.16.1.0 255.255.255.0 192.168.1.2
     - 172.16.1.0 (destination network address)
     - 255.255.255.0
    (subnet mask of desination . . . can be summarized)
     - 192.168.1.2 (next-hop router's interface ... s0/0/1 etc)


    ........................................................................................................

    (2) Using an Exit Interface Static Route

    R3(config)# ip route 172.16.1.0 255.255.255.0 s0/0/1
     - 172.16.1.0 (destination network address)
     - 255.255.255.0
    (subnet mask of desination . . . can be summarized)
     - s0/0/0 (next-hop router's interface ... s0/0/1 etc)

    ........................................................................................................

    (3) Using a Default Static Route

    R3(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.2

    - 192.168.1.2 (next-hop router's interface ... s0/0/1 etc)

    ........................................................................................................

    (4) Using a Summary Static Route

    R3(config)# ip route 172.16.0.0 255.255.252.0 192.168.1.2

    - 172.16.0.0 (summarized AND destination networks)
    - 255.255.252.0 (summarized AND destination networks sumbet mask)

    - 192.168.1.2 (next-hop router's interface ... s0/0/1 etc)

    .........................................................................................................
     
  6. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ....................................................................................................

    CCNA 2, RIP version 1

    ...................................................................................................

    Administrative distance (120)

    R# show ip route
    - R  192.158.1.0/24 [120/1] via 192.168.6.2,  00:00:05,  Serial0/0/0

    R# show ip protocols

    ....................................................................................................

    R1# router ?
    R1# router rip
    R1# no router rip
    ..........................................................................................................

    At least 1 active interface with an associated network command is needed
    before RIP routing will start.



    R1(config-router)# network 192.168.1.2
     - directly connected classful address

    If you enter subnet address as above, IOS automatically converts to classful network address. Example, R1 will convert to 192,168.1.0 network. See in running-config.


    The network command:

    Enables
    RIP on all interfaces that belong to a specific network. Associated interfaces will now both send and receive RIP updates.

    Advertise
    s
    the specified network in RIP routing updates sent to other routers every 30 seconds.
    ............................................................................................................

    Verifying/Troubleshooting RIP

    R1# show ip route (on each router)
    R1# show ip protocols
    R1# debug ip rip

    Convergence occurs for example when all 3 routers has a route to every network of topology in it's routing table.
    ..........................................................................................................

    Interpreting show ip route in RIP

    R 192.168.5.0/24 [120/2] via 192.168.2.2, 00:00:23, Serial0/0/0

    R
    (identifies the source of the route as RIP)
    192.168.5.0/24 (remote network address and subnet mask)
    [120/2] (AD value/metric ... hop distance)
    via 192.168.2.2 (next-hop IP router to send traffic to remote network)
    00:00:23 (how many seconds have passed since the last update)
    Serial0/0/0 (exit interface destined for the remote network)

    This listing of a route with an R code is a quick way to verify that RIP is actually running on this router.
    ............................................................................................................

    Interpreting show ip protocols in RIP

    - use if a network is missing from the routing table
    - confirms RIP routing is configured
    - confirms the correct interfaces send and receive RIP updates
    - confirms the router advertises the correct networks
    - confirms RIP neighbors are sending updates
    ............................................................................................................

    Interpreting debug ip rip in RIP

    - split horizon rule in effect in updates



    Must disable debug after finished
     R1#1 no debug ip rip
     R1#1 undebug all

    .............................................................................................................

    Passive Interfaces

    Bandwidth is wasted transporting unnecessary updates. RIP updates are broadcast, switches will forward the updates out all ports.

    Advertising updates on a broadcast network is a security risk. RIP updates can be intercepted with packet sniffing software. Routing updates can be modified and sent back to the router, corrupting the routing table with false metrics that misdirect traffic.
    ...........................................................................................................

    R1(config-router)# passive-interface fa0/0

    Prevents the transmission of routing updates through a router interface but still allows that network to be advertised to other routers.

    Confirm with show ip protocols

    ............................................................................................................

    Boundary routers summarize RIP subnets from 1 major network to the other, updates for example the 172.30.1.0, 172.30.2.0 and 172.30.3.0 networks will automatically be summarized into 172.30.0.0 when sent out R2's Serial 0/0/1 interface to another network.

    Routers running RIPv1 are limited to using the same subnet mask for all subnets with the same classful network.

    Use debug to view automatic summarization.

     
  7. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ....................................................
    CCNA 2

    ..................................
     
  8. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ....................................................
    CCNA 2

    ..................................
     
  9. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ....................................................
    CCNA 2

    ..................................
     
  10. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ....................................................
    CCNA 2

    ..................................
     
  11. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ....................................................
    CCNA 2

    ..................................
     
  12. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ....................................................
    CCNA 2

    ..................................
     
  13. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ....................................................
    CCNA 2

    ..................................
     
  14. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ........................................................................................

    CCNA 2, EIGRP
    ........................................................................................

    Successor

    - A neighboring router that is used for packet forwarding 
     is the least-cost route to the destination network
    - it's IP address in routing table after word "via"


    Feasible Distance (FD)

    - the lowest calculated metric to reach the destination network
    - metric in routing table (2nd number inside brackets)

    9.4.2.1 feasible distance question

    Feasible Successor

    - a neighbor who has a loop-free backup path to the same network as the successor by satisfying the feasibility condition


    Feasible Condition  (FV)

    - when a neighbor's reported distance to a network is less than the local router's feasible distance to the same destination network


    Reported Distance (RD)

    - a neighbor's feasible distance to the same destination network

     
  15. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ....................................................
    CCNA 2

    ..................................
     
  16. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    ........................................................................................

    CCNA 2, EIGRP
    ........................................................................................

    R1(config)# router eigrp 1
    R1(config-router)# network 192.168.10.4 0.0.0.3

    R1# show ip protocols

    R1# show ip eigrp neighbors

    R1# show ip route

    R1# show interface s0/0/0


    R1# show ip eigrp neighbors

    R2# show eigrp topology

    R2# show ip eigrp topology 192.168.1.0

    R3(config)# interface lo1
    R3(config-if)# ip address 192.168.2.0 255.255.255.0
    R3(config-if)# interface lo2
    R3(config-if)# ip address 192.168.3.0 255.255.255.0

    R3(config)# router eigrp 1
    R3(config-router)# network 192.168.2.0
    R3(config-router)# network 192.168.3.0

    R3(config)# interface s0/0/0
    R3(config-if)# ip summary-address eigrp 1 192.168.0.0 255.255.252.0
    R3(config-if)# interface s0/0/1
    R3(config-if)# ip summary-address eigrp 1 192.168.0.0 255.255.252.0

    R2(config)# ip route 0.0.0.0 0.0.0.0 lo1
    R2(config)# router eigrp 1
    R2(config-router)# redistribute static

    .......................................................................................................

    R1(config-router)# metric weights 0 1 0 1 0 0
    (default tos, k1, k2, k3, k4, k5)

    ......................................................................................................

    R1# debug eigrp fsm

    ......................................................................................................

    Limiting EIGRP to 50% of link's bandwidth

    R1(config)# interface s0/0/0
    R1(config-if)# bandwidth 64
    R1(config-if)# ip bandwidth-percent eigrp 1 50

    .....................................................................................................


    Configuring Hello Intervals and Hold Times from Default
    - hold time intervals > hello interval

    R1(config)# interface s0/0/0
    R1(config-if)# ip hello-interval eigrp 1 60
    R1(config-if)# ip hold-time eigrp 1 180
    R1(config-if)# end

    ......................................................................................................

     
  17. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    .......................................................................................

    CCNA 2, Link State Routing Protocols
    ......................................................................................


    1. Each router learns about its own links, its own directly connected networks. This is done by detecting that an interface is in the up state.

    2. Each router is responsible for meeting its neighbors on directly connected networks. Similar to EIGRP, link state routers do this by exchanging Hello packets with other link-state routers on directly connected networks.

    3. Each router builds a Link-State Packet (LSP) containing the state of each directly connected link. This is done by recording all the pertinent information about each neighbor, including neighbor ID, link type, and bandwidth.

    4. Each router floods the LSP to all neighbors, who then store all LSPs received in a database. Neighbors then flood the LSPs to their neighbors until all routers in the area have received the LSPs. Each router stores a copy of each LSP received from its neighbors in a local database.

    5. Each router uses the database to construct a complete map of the topology and computes the best path to each destination network. Like having a road map, the router now has a complete map of all destinations in the topology and the routes to reach them. The SPF algorithm is used to construct the map of the topology and to determine the best path to each network.


     
  18. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    .......................................................................................

    CCNA 2, Link State Routing Protocols
    .......................................................................................

    Step 1

    Information about the state of roters own directly connected networks:
    - the interface's IP address and subnet mask.
    - the type of network (Fast ethernet, serial)
    - the cost of that link.
    - any neighbor routers on that link
    ...................................................................................................

    Step 2

    - Hello packets and replies
    - usually serial
    ...................................................................................................

    Step 3

    R1; Ethernet network 10.1.0.0/16; Cost 2
    R1 -> R2; Serial point-to-point network; 10.2.0.0/16; Cost 20
    R1 - /> R3; Serial point-to-point network; 10.3.0.0/16; Cost 5
    R1 - /> R4; Serial point-to-point network; 10.4.0.0/16; Cost 20
    ..................................................................................................

    Step 4

    Whenever a router receives an LSP from a neighboring router, it immediately sends that LSP out all other interfaces except the interface that received the LSP, thus flooding effect.


    Unlike distance vector routing protocols that must first run the Bellman-Ford algorithm to process routing updates before sending them to other routers, link-state routing protocols calculate the SPF algorithm after the flooding is complete. Therefore convergence much faster than distance vector routing protocols.

    LSPs need not be sent periodically. Only during initial startup, change in topology.

    Sequence numbers and aging informationalso included.
    ..........................................................................................................

    Step 5

    After each router has propagated its own LSPs using the link-state flooding process, each router will then have an LSP from every link-state router in the routing area.

    ..........................................................................................................

    Each router constructs its own SPF tree independently from all other routers. The link-state databases used to construct those trees must be identical on all routers.
    ..........................................................................................................

    Routing table built from SPF tree.
    - directly connected networks
    - other sources, example static routes

    ..........................................................................................................


     
  19. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    .......................................................................................

    CCNA 2, Link State Routing Protocols
    .......................................................................................


    Advantages


    Each router builds own topological mao of network to determine shortest parh.

    Immediate flooding of LSPs therefore faster convergence.

    LSPs sent out only iff topoloy change and contain only information about that change.

    Hierarchical design used when implementing multiple areas.

     
  20. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    .................................................................................

    CCNA 2, OSPF  (Open Shortest Path First)
    .................................................................................

    LSA Link-State Advertisements

    LSU
    Link-State Updates (packets used for OSPF routing updates
     
  21. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    .................................................................................

    CCNA 2, OSPF
    ................................................................................







     
  22. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    .................................................................................

    CCNA 2, OSPF
    ................................................................................
     
  23. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    .................................................................................

    CCNA 2, OSPF
    ................................................................................
     
  24. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    .................................................................................

    CCNA 2, OSPF
    ................................................................................
     
  25. You have chosen to ignore posts from InternetGirl. Show InternetGirl's posts

    Re: Homework

    .................................................................................

    CCNA 2, OSPF
    ................................................................................
     

Share